Issues using social login to authenticate
Incident Report for LaterPay GmbH
Resolved
We have deployed a fix.
Posted 11 months ago. Oct 02, 2017 - 10:46 UTC
Identified
We have found the issue and are implementing a fix. We will keep you updated.
Posted 11 months ago. Sep 22, 2017 - 09:42 UTC
Update
We are continuing to investigate the root cause.

In the mean time, if you are trying to restore access to formerly purchased or bought content and login through Facebook in that process, please login before trying to restore access. You can login on https://web.laterpay.net/user/
Posted 11 months ago. Sep 21, 2017 - 18:35 UTC
Investigating
We are investigating issues with social login. Please use your email address and password for login for now.
Posted 11 months ago. Sep 21, 2017 - 17:04 UTC