Banking Downtime
Incident Report for LaterPay GmbH
Resolved
Normal service with our banking partner has been resumed, payments are now being processed as usual
Posted almost 2 years ago. Oct 23, 2016 - 00:22 UTC
Monitoring
Our banking partner is undergoing emergency maintenance until 0200 CEST Sunday 23rd October and we are unable to take payments during this period.

All other services are unaffected.
Posted almost 2 years ago. Oct 22, 2016 - 21:11 UTC