Merchant Analytics is not being updated
Incident Report for LaterPay GmbH
Resolved
This incident has been resolved.
Posted 10 months ago. May 02, 2017 - 14:50 UTC
Investigating
An issue is preventing our Merchant Analytics from being updated. We are investigating.
Posted 10 months ago. May 02, 2017 - 13:52 UTC