Web UI Downtime
Incident Report for LaterPay GmbH
Resolved
Web UI functionality now restored
Posted almost 3 years ago. Sep 24, 2015 - 15:37 UTC
Investigating
We're seeing downtime on our web UI, affecting our purchase dialogs. This is under investigation
Posted almost 3 years ago. Sep 24, 2015 - 15:31 UTC