Merchant UI down
Incident Report for LaterPay GmbH
Resolved
We've identified and fixed a connection issue with our Merchant Admin UI, which should now be fully operational
Posted over 2 years ago. May 21, 2015 - 13:23 EDT
Identified
We've temporarily disabled our Merchant UI while we debug some database issues we're experiencing
Posted over 2 years ago. May 21, 2015 - 08:18 EDT