Payment Issues
Incident Report for LaterPay GmbH
Resolved
The incident has been resolved.
Posted 4 months ago. Jul 03, 2017 - 16:50 EDT
Monitoring
We've deployed a fix and are monitoring the result.
Posted 4 months ago. Jul 03, 2017 - 16:25 EDT
Identified
We've identified the issue and are deploying a fix.
Posted 4 months ago. Jul 03, 2017 - 16:12 EDT
Investigating
We are investigating an issue with payments at the moment.
Posted 4 months ago. Jul 03, 2017 - 15:55 EDT