Issues with PayPal payments
Incident Report for LaterPay GmbH
Resolved
The incident involving PayPal has been resolved and we are once again accepting PayPal payments. We apologize for the unavailability.
Posted about 2 months ago. Oct 27, 2017 - 12:09 EDT
Identified
We have identified the issue with PayPal payments and are working on helping the affected users and fixing the issue. PayPal remains disabled as a payment option. Credit Cards and Bank Transfers remain unaffected and are working well.
Posted 2 months ago. Oct 12, 2017 - 03:58 EDT
Investigating
We're investigating issues with PayPal payments. This payment option is currently disabled.
Posted 2 months ago. Oct 11, 2017 - 09:06 EDT