DB connection issue affecting some customers
Incident Report for LaterPay GmbH
Resolved
This incident has been resolved.
Posted almost 2 years ago. Dec 16, 2016 - 20:04 UTC
Monitoring
We believe we've rectified the fault, and are continuing to monitor the situation.
Posted almost 2 years ago. Dec 16, 2016 - 19:52 UTC