Email failures
Incident Report for LaterPay GmbH
Resolved
Automated emails are now being sent without error
Posted about 3 years ago. Apr 23, 2015 - 11:50 UTC
Investigating
We're currently experiencing an issue sending some automated emails
Posted about 3 years ago. Apr 23, 2015 - 11:10 UTC