Issue accepting payments
Incident Report for LaterPay GmbH
Resolved
This issue is now resolved and payments are once again being processed successfully. Thank you for your patience.
Posted about 2 months ago. Aug 18, 2017 - 10:58 EDT
Investigating
We are currently experiencing issues related to accepting payments. This does not affect articles that you have already purchased. We are working to resolve this issue and hope to have it fixed shortly. Thank you for understanding.
Posted about 2 months ago. Aug 18, 2017 - 10:29 EDT