Several services affected by an expired SSL certificate
Incident Report for LaterPay GmbH
Resolved
This incident has been resolved.
Posted over 1 year ago. Jun 27, 2017 - 09:08 UTC
Identified
We're in the process of updating SSL certificates for several of our services in the Sandbox environment. Currently it's not possible to register SEPA payment methods and payment confirmation emails will not be sent.
Posted over 1 year ago. Jun 27, 2017 - 08:33 UTC