Connection issues to payment service provider
Incident Report for LaterPay GmbH
Resolved
The service interruption has been confirmed and resolved by our payment service provider. We apologize for any inconvenience this might have caused.
Posted about 1 year ago. Aug 14, 2017 - 08:26 UTC
Monitoring
While we haven't got a service interruption confirmation from our payment service provider the issue seems to be resolved. We'll keep monitoring the situation.
Posted about 1 year ago. Aug 14, 2017 - 06:43 UTC
Investigating
We're experiencing issues with connecting to our payment service provider. We'll update with more information when we know more.
Posted about 1 year ago. Aug 14, 2017 - 06:05 UTC