EU merchant login links not working correctly
Incident Report for LaterPay GmbH
Resolved
EU merchant login links are now working normally. The incident is resolved.
Posted Aug 29, 2018 - 18:56 UTC
Investigating
We have identified problems with EU merchant login links pointing to the US, so if you are in the EU you will end up in the wrong region, probably unknowingly, and get a failed login because the user doesn't exist. The EU and US sites themselves are unaffected, it is just the links from www.laterpay.net that are not working correctly. We are working on fixing this.

As a workaround in the meantime, here are the correct merchant login links:

- US: https://web.uselaterpay.com/merchant
- EU: https://web.laterpay.net/merchant

Related to this issue we have just fixed the merchant registration links, so all merchants can now register correctly in whatever region they are in.
Posted Aug 29, 2018 - 16:49 UTC
This incident affected: Homepage.