Invoice creation delayed
Incident Report for LaterPay GmbH
Resolved
This incident has been resolved.
Posted Mar 19, 2018 - 20:37 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 19, 2018 - 20:10 UTC
Investigating
We are currently experiencing problems creating and sending invoices. We will update the incident when we have more information
Posted Mar 19, 2018 - 19:25 UTC