Mastercard payments impacted
Incident Report for LaterPay GmbH
Resolved
This incident has been resolved.
Posted Jun 12, 2018 - 08:59 UTC
Investigating
Our payment processor is experiencing problems processing Mastercard payments. We will provide updates as we have them.
Posted Jun 12, 2018 - 08:53 UTC
This incident affected: Production Platform.